Seat Ateca SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
I have a faulty revcounter in my car and it has been like that from day 1. The needle goes up and down the dial in jumps ie it is not smooth. Took it into the garage who confirmed it needed a complete replacement binnacle. When it arrived in the garage they called to arrange a time to fit it. Took it in (a round trip of 60 miles) and received a call later that day to say the wrong part was received. Not best pleased!!
Did they not check the part when they received it before arranging a time to fit it. Now I find that the part is on back order and nobody knows when it will be received. :evil:

Also I had a warning come up on the dashboard saying "Front Assist - radar sensor impaired". Assumed it was just some dirt or something on the sensor (it is behind the Seat badge on the front grille). Cleaned it up but no joy. Two days later the message has disappeared. Will keep an eye on it over the next few weeks.
 

·
Registered
Joined
·
1,865 Posts
:cry:

The front assist one a few of us have had but not for any great length of time ... mine has done it in driving rain most
 

·
Registered
Joined
·
237 Posts
Mine told me today conveniently for me outside Seat Hull that it had a problem with its left front tyre £20 lighter and a 2 inch nail in hand I am mobile again !
 

·
Registered
Joined
·
918 Posts
Radar sensor behind the SEAT badge on the front grille seems to be very sensitive to rain and/or dirt, unfortunately! I think it may have been Tell who noted that (maybe in Germany?) there is talk of replacing badge to deal with this issue :?:
 

·
Banned
Joined
·
2,739 Posts
Or it might have been Kindness.

However I did read last night on the UK Tiguan site that when you turn front assist off it only remembers it till you do a restart on the button. I'm sure the people who have turned it off on the Ateca have it permanently turned off... perhaps it isn't or perhaps a difference between the Mk2 Tiguan and the Ateca in this respect.

I did find my virtual pedal not working today, could have been wet weather desensitised or the car went into power saving. Once I used the button on the tailgate it was fine.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top