Seat Ateca SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I opened the bonnet on my Ateca for the first time today to check the oil and water level.

Opened with the handle in the passenger foot well no problem, but when I went to put it back down it refused to go all the way back down.

For some reason there appears to be some sort of metal bar across the locking mechanism that seems to be controlled by a spring, see the picture attached. The release cable seems to unlock the main catch, but the bar seems stuck across and locking and unlocking the car, starting the engine all do not appear to do anything.

Am I missing something stupid or is something broken?

Barry
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter · #2 ·
Well that was interesting!

Can report SEAT Roadside Assistance (aka. The AA) were very efficient. Turned up within 10 minutes of my call and spent more time doing the paperwork than fixing it :)

Seems the mechanism had frozen, probably as it hadn't been used and the wet/cold weather.

Lots of lubricant (AA version of WD40) and loosening the catch with a screwdriver and it appears to be working fine again. Will try it again next week when I am less busy to make sure it stays working! At least I know how the latch works now...

Barry
 

·
Registered
Joined
·
526 Posts
Good to know Barry, thanks for sharing!
 

·
Registered
Joined
·
778 Posts
Thanks for updating too - really should have a separate niggles & issues stickies thread for things like this!
 
1 - 5 of 5 Posts
Top