Seat Ateca SUV Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
Hey All,

Has anyone else replaced their interior lights with LED ones? (mines an SE tech and didn't come with the ambiance LED light things). Anyway - all went went - replaced the glove box - the 2x sunvisor, 2x front reading lights and 2x rear roof lights. Still waiting for a bulb for the boot - all were working fine. On Saturday i was driving in the rain with lights on and my dad asked why no cd player so i told him to open the glove box - he did - and i got a audio "bing" dash warning along with warning on the dash - pic of car with flashing tailgate and all the interior roof lights flashed on and off like a disco - until the glove box was shut...... now - it seems to happen intermittently on opening the glove box when i have the cars lights on (assume this activates the glovebox light) but does keep happening - tbh i'm not too concerned as how often do you go in the glove box - but seems weird. I'm thinking maybe the bulbs aren't error free (they were sold as error free - but you know ebay..)

Anyone else had any issues when replacing interior lights?
 

·
Banned
Joined
·
2,739 Posts
Did you use this thread which was based on what people were doing to their Tiguans

http://atecaforums.co.uk/viewtopic.php?f=11&t=729

The penny dropped that mine were LED after I pulled the boot one out and read the serial number of the unit. Being an Xcellence it is LED already on those :).

You will being seeing a Can bus error. Perhaps you could try a difference manufacturer that say Can bus free error. The FlashWolves ones on the reversing lights are totally fine, that's one of the few bulbs that isn't LED on the Xcellence.

There is a way of turning off Can bus errors via Vagcom etc but that I'd say that would be more hassle than changing the bulb for another.

Are the sizes that they were using on the Tiguan the same for the Ateca, I assumed they were ?.

Trunk light is festoon 41/41mm
Sunvisor lights are festoon 38/39 mm
Glove box is T10 W5W.
They didn't say which manufacturer worked on that thread. Seems you just got to try a different bulb on the glovebox.

Yes, so a list of what works and what doesn't by source would be good.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #3 ·
Nice one cheers Tell - i'll have a look at that thread in full after work.

The sizes seem the same (although i used 40/41mm ones all round as bought a pack of 10 - you just need to push them in a bit harder to slightly bend the contact - never been an issue in any other of my cars doing that, so it may well be that it is the glovebox T10 bulb that is erroring - i'll try changing it over and investigate.
 

·
Banned
Joined
·
2,739 Posts
I think if Howie goes back to the original bulb in the glovebox and sees how that goes, then finds a completely different maker that may be of a higher standard that is more cam bus friendly. The bit of circuit should be in the bulb. If it was me I'd probably forgo the LED bulb in the glovebox if the cabin ones worked fine and couldn't get a solution via a more pricey bulb. I did wonder how a loose connection manifests itself, probably in a similar manner, my be worth checking.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #6 ·
Cheers Leon for the link - yeah this looks a bit drastic for a brand new car. I'm with Tell on this one - once i get a chance i'll go back to the original glovebox bulb and see if it solves the issue - the interior leds are a huge improvement and so i can live without the glove box one if it resolves the issue.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #7 ·
Tell, Leon - update

I replaced the boot light with LED when it arrived and the fault has not reoccurred (without changing the glovebox back to standard) ..... SO i have concluded (whether it is true or not who knows!) that the circuit for the interior lights are all linked and they only like the same resistance across the board. As it makes sense that the error picture on the dash was flashing the boot as error - which at the time was the only one not to be LED. I am assuming they don't put different wiring in for SE tech v excellence models and they are LED as standard.

So so far so good - i'll keep you updated

The LED i used for the boot is this led panel - it is amazing! and i would highly recommend replacing - even the standard LED on the excellence as it lights up all of the boot:-

http://www.ebay.co.uk/itm/331883896101?_trksid=p2060353.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT
 

·
Banned
Joined
·
2,739 Posts
Howie thanks. Yes may be. If that festoon light has 48 elements it will be bright, unless the product information is written in a weird way. The Xcellence just has one SMD in the boot LED which is a sealed affair. Quite expensive to replace when I looked the code up.

Do you want to provide a link to all the interior LEDs you put in so others can follow if it proves successful.
 

·
Registered
Joined
·
32 Posts
Getting ready to pick up my Ateca today and I have stripped all the internal LEDs I had put into my Leon out. From the sounds of it I'll be able to swap them straight into the Ateca, great news.

I had red LED for the front footwell in the Leon, does the Ateca have footwell lights?
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #10 ·
Kaizer83 said:
Getting ready to pick up my Ateca today and I have stripped all the internal LEDs I had put into my Leon out. From the sounds of it I'll be able to swap them straight into the Ateca, great news.

I had red LED for the front footwell in the Leon, does the Ateca have footwell lights?
Yes the Ateca has footwell lights - i haven't actually replaced them yet come to think of it..... but the issue i was seeing has gone for the moment after replacing the boot light. Good idea replacing the foot well lights with a different colour mind... i'll get on to that.

I'll sort out some pics of all the lights and what bulbs i bought for each when i can - car is in getting the rear windows tinted today.
 

·
Registered
Joined
·
979 Posts
Kaizer83 said:
Getting ready to pick up my Ateca today and I have stripped all the internal LEDs I had put into my Leon out. From the sounds of it I'll be able to swap them straight into the Ateca, great news.

I had red LED for the front footwell in the Leon, does the Ateca have footwell lights?
Yes the SE models onwards has the ambient spot lighting and front footwell illumination :)
 

·
Registered
Joined
·
32 Posts
I'm not sure if red will will suit the Ateca interior with it being partly blue. The Leon was grey and the red footwell complimented the red/orange of most of the dashboard lights.

I will post up pictures too once I've swapped and see what people think.

Very excited now, just need to wait for my daughter to eat her lunch then we're off to collect it!
 

·
Banned
Joined
·
2,739 Posts
I didn't like to mention the footwell lights since it was going well. They are white in the Xcellence. I think they might be the same unit perhaps as the boot LED that is also sold on parts as a footwell light without crawling around I haven't looked at them apart from the hassle of leaving the left one out at build which the garage sorted out. Probably another bulb change for you. You probably don't want them too bright else it would be a distraction driving.

The full LED interior lighting in the Xcellence isn't amazingly bright, darker than by old Altea in what it throws out so upgrading a non Xcellence interior to full LED you might get a better level of light. The Xcellence ones perhaps are their to study their spot light beauty rather than practical down lighting.

So yes if both of you table the led units and web links to suppliers it will help others get it right first time with things that work.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #14 ·
Yeah they are the same units as glove box and boot, i know this as i wondered why only the drivers side had a light when i was playing with the brightness through the computer to then check and find that SEAT hadn't tucked the carpet in properly in the passenger side and so blocking the light.
 

·
Banned
Joined
·
2,739 Posts
That ones a known error, but not fitting one is known in Germany. I seem to have been the only UK customer that's been effected on that one. They probably swigged their tea as it past by on the production line and it wasn't put in. The garage looked at it and said all the wiring is there, we will order you one and fitted it a week later.
 

·
Registered
Joined
·
64 Posts
Howie669 said:
Kaizer83 said:
Getting ready to pick up my Ateca today and I have stripped all the internal LEDs I had put into my Leon out. From the sounds of it I'll be able to swap them straight into the Ateca, great news.

I had red LED for the front footwell in the Leon, does the Ateca have footwell lights?
Yes the Ateca has footwell lights - i haven't actually replaced them yet come to think of it..... but the issue i was seeing has gone for the moment after replacing the boot light. Good idea replacing the foot well lights with a different colour mind... i'll get on to that.

I'll sort out some pics of all the lights and what bulbs i bought for each when i can - car is in getting the rear windows tinted today.
Hi Howie,

How have you got on with replacing lights for the Ateca?

Thanks
Andy
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #17 ·
Andyam said:
Howie669 said:
Kaizer83 said:
Getting ready to pick up my Ateca today and I have stripped all the internal LEDs I had put into my Leon out. From the sounds of it I'll be able to swap them straight into the Ateca, great news.

I had red LED for the front footwell in the Leon, does the Ateca have footwell lights?
Yes the Ateca has footwell lights - i haven't actually replaced them yet come to think of it..... but the issue i was seeing has gone for the moment after replacing the boot light. Good idea replacing the foot well lights with a different colour mind... i'll get on to that.

I'll sort out some pics of all the lights and what bulbs i bought for each when i can - car is in getting the rear windows tinted today.
Hi Howie,

How have you got on with replacing lights for the Ateca?

Thanks
Andy
Hello - all interior lights were replaced - that is 4x ceiling (2 front with 501 led's, 2 rear with led festoon's) 2x sun visor (led festoons), glove box (501 LED), 2 footwell lights - BLUE 501 LED's - look great :) and i replaced the interior boot light with a small LED panel - i think i posted the link somewhere above - everything is fine and i have not experienced any repeat of the issue i had originally reported.
 

·
Registered
Joined
·
64 Posts
Howie669 said:
Andyam said:
Howie669 said:
Yes the Ateca has footwell lights - i haven't actually replaced them yet come to think of it..... but the issue i was seeing has gone for the moment after replacing the boot light. Good idea replacing the foot well lights with a different colour mind... i'll get on to that.

I'll sort out some pics of all the lights and what bulbs i bought for each when i can - car is in getting the rear windows tinted today.
Hi Howie,

How have you got on with replacing lights for the Ateca?

Thanks
Andy
Hello - all interior lights were replaced - that is 4x ceiling (2 front with 501 led's, 2 rear with led festoon's) 2x sun visor (led festoons), glove box (501 LED), 2 footwell lights - BLUE 501 LED's - look great :) and i replaced the interior boot light with a small LED panel - i think i posted the link somewhere above - everything is fine and i have not experienced any repeat of the issue i had originally reported.
I replaced the glovebox light with one of my LED plate lights from my A4 I had...have so many of them! The only others I am thinking of changing is thenfootwells and boots for a little more brightness especially the boot
 

·
Registered
Joined
·
38 Posts
Howie669 said:
Hey All,

Has anyone else replaced their interior lights with LED ones? (mines an SE tech and didn't come with the ambiance LED light things). Anyway - all went went - replaced the glove box - the 2x sunvisor, 2x front reading lights and 2x rear roof lights. Still waiting for a bulb for the boot - all were working fine. On Saturday i was driving in the rain with lights on and my dad asked why no cd player so i told him to open the glove box - he did - and i got a audio "bing" dash warning along with warning on the dash - pic of car with flashing tailgate and all the interior roof lights flashed on and off like a disco - until the glove box was shut...... now - it seems to happen intermittently on opening the glove box when i have the cars lights on (assume this activates the glovebox light) but does keep happening - tbh i'm not too concerned as how often do you go in the glove box - but seems weird. I'm thinking maybe the bulbs aren't error free (they were sold as error free - but you know ebay..)

Anyone else had any issues when replacing interior lights?
Hello there,

Any chance you could tell me how you were able to get the round covers of the two internal lights where the sunglasses holder is?

Thanks.

Fever
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #20 ·
FeverSeven said:
Hello there,

Any chance you could tell me how you were able to get the round covers of the two internal lights where the sunglasses holder is?

Thanks.

Fever
Hi - as far as i remember a small flat head screw driver pops the whole cover off - not just the circle covers. I can check once i get back in the car.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top