Infotainment system failure

Faults and Technical chat for the Seat Ateca
Den48
Posts: 50
Joined: Thu Apr 04, 2019 1:36 pm

Infotainment system failure

Post by Den48 » Thu Sep 05, 2019 6:50 pm

Hi,
Reversed off my drive as usual this afternoon, parking assist worked as usual then the seat screen showed for a few seconds and the whole system died , blank screen no response from any of the buttons phone,nav,radio etc and no response when the system was switched on/off.

After about 10 mins of driving and wondering what it could be the seat screen re appeared and the unit started to function normally.

Has Anyone else experienced this ? Would be grateful for any info

Ateca 1.5 manual 19my

Jettabout
Posts: 94
Joined: Sun Feb 17, 2019 12:09 pm
Location: Bonny West o' Scotland

Re: Infotainment system failure

Post by Jettabout » Thu Sep 05, 2019 7:14 pm

Did you have anything plugged into the two USB ports below the radio as they apparently don't like heavy power items as they are powered through the radio which can trip out then reset after a wee while? I read somewhere that nothing heavier than a charging phone should be plugged in there, for powering other things it's best to use the power/cigarette lighter socket next to the USBs. I even charge my phone in there just to be safe.

Dave.
Dave.
2019 Ateca SE Tech 2.0ltr Tdi, Rodium grey, now with spare wheel, mudflaps, boot liner but still loving it...

Den48
Posts: 50
Joined: Thu Apr 04, 2019 1:36 pm

Re: Infotainment system failure

Post by Den48 » Thu Sep 05, 2019 7:27 pm

Hello Dave
Thanks for the reply, no I had nothing plugged into the USB sockets, interesting about the reset that you described ,the failure seemed to me like an update or possibly this reset you mention especially as the seat screen showed just before it went blank.

User avatar
Wilber6
Posts: 41
Joined: Thu Aug 30, 2018 11:33 am
Location: Merseyside

Re: Infotainment system failure

Post by Wilber6 » Fri Sep 06, 2019 8:14 am

Hi Den48.
Yes I had a similar thing happen to me a few months ago. I started the car after a day parked at the station car park and pressed the infotainment 'on' button. Nothing, just a blank screen. I turned the ignition on and off a few times, but no change. I had nothing plugged in to any USB ports, nor any other power draining accessories on, like hrw. Drove home and parked up. Started the car about 2 hours later and all was fine. No recurrence since. Still don't know what caused the issue.
Wilber6
Wilber6
Ateca 1.0 SE Technology Ecomotive in Nevada White metallic, Nora Blue interior, 18" bi-colour alloys, space saver spare wheel, privacy glass.
Merseyside

vectra
Posts: 420
Joined: Wed Apr 03, 2019 11:14 am
Location: Ireland
Contact:

Re: Infotainment system failure

Post by vectra » Fri Sep 06, 2019 10:08 am

I wouldnt worry too much for now,
I have had this happen in several cars previously,
MY19 Ateca FR 1.5Tsi DSG Velvet red, Digital cockpit, Beats audio, Winter pack, Leather, adaptive cruise, Electric boot, Kessy, Lane assist, Connectivity box, Alarm, Kessy, Rear view Camera. 8-)

Den48
Posts: 50
Joined: Thu Apr 04, 2019 1:36 pm

Re: Infotainment system failure

Post by Den48 » Fri Sep 06, 2019 11:16 am

Ok, thanks all for your replies, hopefully it's a one off.

Tet70
Posts: 524
Joined: Sun Mar 26, 2017 9:40 am
Location: Finland

Re: Infotainment system failure

Post by Tet70 » Sat Sep 07, 2019 9:18 am

When this happens next time, try pressing the 'on' button and hold it down for a good 10 seconds. That will reset the head unit.
Jungle Green 1.4 TSI 4Drive DSG Style + quite a lot of extras. Delivered in less than 8 months. :roll:

jobld
Posts: 3
Joined: Thu Dec 14, 2017 9:19 pm

Re: Infotainment system failure

Post by jobld » Fri Nov 29, 2019 11:57 am

28/11/19 Infotainment display crashed to black screen, only radio working, recorded on phone and switched ignition on & off 5 times still black except remeber your phone message at switch off. Back to dealers and no fault found even though they had the video evidence. Contacted Seat Customer Care and they spoke to dealer who confirmed that they would take action if they could see the fault at the garage, the video was not sufficient apparently. The car's sat nav had been reset twice before and they reset again, Now wait and see time!

O.Lee
Posts: 61
Joined: Sat Mar 02, 2019 12:12 am
Location: Barcelona

Re: Infotainment system failure

Post by O.Lee » Fri Nov 29, 2019 8:43 pm

Happened a week ago... nothing at all. Drove until the next traffic light (5min or so) then switched off the engine and and again, and system came back. Still rather annoying as I needed the Nav
Ateca 1.5 EcoTSI, 110 KW, (150 CV) Start/Stop Xcellence Plus 2018 model

HappyMan
Posts: 14
Joined: Wed Feb 20, 2019 1:39 pm

Re: Infotainment system failure

Post by HappyMan » Mon Dec 30, 2019 2:55 pm

I am having this issue rather regularly at the moment. It's also freezing the screen so nothing works on the touchscreen or the buttons to the side. I obviously reset the system by pressing the on/off button for 10 or so seconds, but it's rather annoying especially when it happened whilst i was reversing and the camera wouldn't work. I"m wondering if I should simply go back to the dealer and as them to make sure it's all been upgraded to the latest software, what do you think?

Post Reply