Drive Mode resets to Normal after a re-started engine

All Seat Ateca related discussions
Fred99
Posts: 1312
Joined: Wed Jun 29, 2016 5:11 pm
Location: Granada, Spain

Re: Drive Mode resets to Normal after a re-started engine

Post by Fred99 » Mon Nov 05, 2018 9:52 pm

I still don’t see the problem. If it did reset the dial to normal, you would still have to rotate the dial to the setting you want if is different to the normal setting. Either way, you cannot avoid having to do something unless you always drive in the normal setting.

Blame the tree huggers!
1.4TSI DSG Xcellence delivered 2/3/17 after 6 months wait. Brilliant Silver. 18" machined alloys. Park Assist. 360º cameras. Power boot. All driver assists. Alcantara. SEAT sound.


Tet70
Posts: 478
Joined: Sun Mar 26, 2017 9:40 am
Location: Finland

Re: Drive Mode resets to Normal after a re-started engine

Post by Tet70 » Tue Nov 06, 2018 10:01 am

Fred99 wrote:
Mon Nov 05, 2018 9:52 pm
I still don’t see the problem. If it did reset the dial to normal, you would still have to rotate the dial to the setting you want if is different to the normal setting. Either way, you cannot avoid having to do something unless you always drive in the normal setting.

Blame the tree huggers!
I agree with leWrat, and I can see the problem very clearly. The problem is, that after restart, you don't know which settings are in effect. Of course you CAN always turn the knob to set the mode to your preference. My first car, my father's old Lada, had this problem that the headlights did not work in freezing temperatures. After turning the headlight switch on, I had to also reopen the driver's door and slam it close, in order to get the lights on. Now I could do that very easily, every time. So was it acceptable, that I had to do it? I don't think so. It was a fault, period.

We should not blame tree huggers, because they did not require VW group to give us this mixed-up partial profile setup. They only required normal profile, and that's what we should get. This mixed up, partial, something-other-than-indicated profile is all manufacturer's fault. And it's so easy to fix with couple of lines of code in the BCU (or whatever controller controls the knob indicator LEDs), that it's a very lousy excuse to blame tree huggers.

Fortunately, I'm not affected by this bug personally. My Ateca is old enough, it does not do this partial reset after restart. :)
Last edited by Tet70 on Tue Nov 06, 2018 10:04 am, edited 1 time in total.
Jungle Green 1.4 TSI 4Drive DSG Style + quite a lot of extras. Delivered in less than 8 months. :roll:


leWrat
Posts: 52
Joined: Sun Oct 14, 2018 8:42 pm
Location: United Kingdom

Re: Drive Mode resets to Normal after a re-started engine

Post by leWrat » Tue Nov 06, 2018 10:03 am

As you say, either way we have to turn the profile dial if it was in something other than "normal" when turning the engine off (assuming we don't want the "normal" profile).
However my preference is that the Driving profile dial displays the profile actually being used rather than potentially displaying the wrong profile.

Sadly I am sure that VAG will not be issuing an update to change it to the way I would prefer it to work so, even though I have asked them nicely. :o
MY19 Ateca Xcellence Lux 1.5 in Rhodium Grey with spacesaver wheel.


ateca_turkiye
Posts: 2
Joined: Mon Jan 07, 2019 8:09 am

Re: Drive Mode resets to Normal after a re-started engine

Post by ateca_turkiye » Mon Jan 07, 2019 8:16 am

ill buy a new 2018 model ateca.. same problems ... drive profile cant save ..car always restarting normal mode..my other car is leon fr 2016, driver profile perceftly saved last state (eco - normal ) ...

is this a bug? or new standart


Felix
Posts: 22
Joined: Wed Nov 14, 2018 8:12 pm

Re: Drive Mode resets to Normal after a re-started engine

Post by Felix » Mon Jan 07, 2019 9:35 am

That's actually interesting what you say. I had 2014 Leon FR and it was exactly the same as Ateca - engine profile returned to normal after restart. Other things stayed at "sport".
It's not a bug, it's a feature (as Steve Jobs used to say :) ). It's actually done for some eco reasons. Annoying, yes, but to be honest i don't know if in other brands (don't mean VAG) it's done differently.


Tet70
Posts: 478
Joined: Sun Mar 26, 2017 9:40 am
Location: Finland

Re: Drive Mode resets to Normal after a re-started engine

Post by Tet70 » Mon Jan 07, 2019 9:40 am

Felix wrote:
Mon Jan 07, 2019 9:35 am
That's actually interesting what you say. I had 2014 Leon FR and it was exactly the same as Ateca - engine profile returned to normal after restart. Other things stayed at "sport".
It's not a bug, it's a feature (as Steve Jobs used to say :) ). It's actually done for some eco reasons. Annoying, yes, but to be honest i don't know if in other brands (don't mean VAG) it's done differently.
Different modes behave differently. In my Ateca, sport mode is reset but eco is retained after restart. On newer cars, both will reset (at least partially). And at least with eco mode, the indicator does not reflect this reset but stays in old mode.
Jungle Green 1.4 TSI 4Drive DSG Style + quite a lot of extras. Delivered in less than 8 months. :roll:


User avatar
Paul.Cambs
Posts: 143
Joined: Wed Jun 20, 2018 10:14 am
Location: Cambridgeshire

Re: Drive Mode resets to Normal after a re-started engine

Post by Paul.Cambs » Mon Jan 07, 2019 10:53 am

I had a Merc auto before Sammy, and that always reverted to 'Comfort' which was what the Co2 emissions were based on I suspect - the manufacturer needed to demonstrate that that mode would be predominately used for the Co2 figure
'Samantha' is a Feb-2018 Samoa FR 2.0 TSi 4Drive DSG
19" Wheels | KESSY | Power Tailgate | Adaptive Cruise | Top View Camera | Seat Sound
Convenience Pack | Winter Pack | Advanced Comfort and Driving Plus Pack | Heated Front Screen


AndyE14
Posts: 275
Joined: Thu Dec 29, 2016 11:32 am

Re: Drive Mode resets to Normal after a re-started engine

Post by AndyE14 » Tue Jan 08, 2019 3:44 pm

Tet70 wrote:
Mon Jan 07, 2019 9:40 am
Felix wrote:
Mon Jan 07, 2019 9:35 am
That's actually interesting what you say. I had 2014 Leon FR and it was exactly the same as Ateca - engine profile returned to normal after restart. Other things stayed at "sport".
It's not a bug, it's a feature (as Steve Jobs used to say :) ). It's actually done for some eco reasons. Annoying, yes, but to be honest i don't know if in other brands (don't mean VAG) it's done differently.
Different modes behave differently. In my Ateca, sport mode is reset but eco is retained after restart. On newer cars, both will reset (at least partially). And at least with eco mode, the indicator does not reflect this reset but stays in old mode.
The transmission display shows which mode is in effect though.

So E for Eco or S for sport before the gear selected on the dash info screen
2.0L 190 PS 4WD DSG, Rodium grey, heated windscreen, panoramic sunroof, xcellence pack, advanced driving & comfort pack plus 2, navigation system plus pack, electric drivers seat, boot divider net.


Post Reply

Return to “Main Seat Ateca chat”