Drive Mode resets to Normal after a re-started engine

All Seat Ateca related discussions
Fred99
Posts: 1384
Joined: Wed Jun 29, 2016 5:11 pm
Location: Granada, Spain

Re: Drive Mode resets to Normal after a re-started engine

Post by Fred99 » Tue Oct 30, 2018 10:33 pm

If you are worried about which setting you actually have, rather than what it says on the dial when you start, all you have to do is move it one position away from the setting and then back and it will give you what you want. It’s a real pain, but so simple to sort out, you will get used to it very quickly.

As I posted earlier, it’s not a bug, just VAG having to conform to these ridiculous emission tests.
1.4TSI DSG Xcellence delivered 2/3/17 after 6 months wait. Brilliant Silver. 18" machined alloys. Park Assist. 360º cameras. Power boot. All driver assists. Alcantara. SEAT sound.


Tet70
Posts: 491
Joined: Sun Mar 26, 2017 9:40 am
Location: Finland

Re: Drive Mode resets to Normal after a re-started engine

Post by Tet70 » Wed Oct 31, 2018 9:26 am

Fred99 wrote:
Tue Oct 30, 2018 10:33 pm
As I posted earlier, it’s not a bug, just VAG having to conform to these ridiculous emission tests.
Well the fact that it's resetting is not a bug, I think you are right about that. But the fact that the mode knob indicator is not reset also, that IS a bug. There is absolutely no justification whatsover to not reset the indicator when the mode is reset.
Jungle Green 1.4 TSI 4Drive DSG Style + quite a lot of extras. Delivered in less than 8 months. :roll:


User avatar
Bedlam
Posts: 250
Joined: Mon Dec 11, 2017 8:47 pm
Location: North Yorkshire

Re: Drive Mode resets to Normal after a re-started engine

Post by Bedlam » Wed Oct 31, 2018 10:53 am

Tet70 wrote:
Wed Oct 31, 2018 9:26 am
Fred99 wrote:
Tue Oct 30, 2018 10:33 pm
As I posted earlier, it’s not a bug, just VAG having to conform to these ridiculous emission tests.
Well the fact that it's resetting is not a bug, I think you are right about that. But the fact that the mode knob indicator is not reset also, that IS a bug. There is absolutely no justification whatsover to not reset the indicator when the mode is reset.
Except that the switch/dial is mechanical not electro/mechanical I guess
Ateca 2.0 TDi Xcellence DSG 4Drive in Black Magic, 19" Exclusive Wheels, Top View Camera, Park Assist, Virtual Tailgate Pedal, Heated Windscreen


CheeseR
Posts: 11
Joined: Thu Jul 26, 2018 1:07 pm

Re: Drive Mode resets to Normal after a re-started engine

Post by CheeseR » Wed Oct 31, 2018 3:26 pm

It is not electromechanical, but it is an infinite knob, so it would be easy to reset it.
SEAT Ateca 1.4 EcoTSI DSG Xcellence Waive in cappuccino beige MY18
Sunroof, NAVI, Top view camera, ACC, Winter pack, Drive assist pack 2.


User avatar
Bedlam
Posts: 250
Joined: Mon Dec 11, 2017 8:47 pm
Location: North Yorkshire

Re: Drive Mode resets to Normal after a re-started engine

Post by Bedlam » Wed Oct 31, 2018 3:35 pm

CheeseR wrote:
Wed Oct 31, 2018 3:26 pm
It is not electromechanical, but it is an infinite knob, so it would be easy to reset it.
So how do you think it would rotate back to "Drive" ???
Ateca 2.0 TDi Xcellence DSG 4Drive in Black Magic, 19" Exclusive Wheels, Top View Camera, Park Assist, Virtual Tailgate Pedal, Heated Windscreen


nitrous
Posts: 74
Joined: Wed Jul 26, 2017 3:41 pm
Location: Kent, UK

Re: Drive Mode resets to Normal after a re-started engine

Post by nitrous » Wed Oct 31, 2018 3:58 pm

@Bedlam, the knob itself doesn't indicate the drive mode position. That is shown by LEDs under the knob itself.
EG: when you select the drive mode from the infotainment centre, the LED indicator changes but the knob itself doesn't move... When the engine is off you can spin the knob round and round and nothing is changed unless the ignition is on.. Not sure whether that makes sense?


User avatar
Bedlam
Posts: 250
Joined: Mon Dec 11, 2017 8:47 pm
Location: North Yorkshire

Re: Drive Mode resets to Normal after a re-started engine

Post by Bedlam » Wed Oct 31, 2018 4:31 pm

nitrous wrote:
Wed Oct 31, 2018 3:58 pm
@Bedlam, the knob itself doesn't indicate the drive mode position. That is shown by LEDs under the knob itself.
EG: when you select the drive mode from the infotainment centre, the LED indicator changes but the knob itself doesn't move... When the engine is off you can spin the knob round and round and nothing is changed unless the ignition is on.. Not sure whether that makes sense?
Thanks, but I understand this, my point was to enquire how anyone can expect the knob to rotate back to indicate drive (Normal) after re-start (which it can't afaik)
Ateca 2.0 TDi Xcellence DSG 4Drive in Black Magic, 19" Exclusive Wheels, Top View Camera, Park Assist, Virtual Tailgate Pedal, Heated Windscreen


CheeseR
Posts: 11
Joined: Thu Jul 26, 2018 1:07 pm

Re: Drive Mode resets to Normal after a re-started engine

Post by CheeseR » Wed Oct 31, 2018 5:07 pm

I guess we don't expect the knob to rotate back just to show the same mode as the gearbox/engine. for that it does not have to rotate anywhere :)
SEAT Ateca 1.4 EcoTSI DSG Xcellence Waive in cappuccino beige MY18
Sunroof, NAVI, Top view camera, ACC, Winter pack, Drive assist pack 2.


Fred99
Posts: 1384
Joined: Wed Jun 29, 2016 5:11 pm
Location: Granada, Spain

Re: Drive Mode resets to Normal after a re-started engine

Post by Fred99 » Wed Oct 31, 2018 6:17 pm

My problem with it is that I use the custom mode. Within that I select Sport for the DSG. It shows custom on switch on but the DSG is in Drive not Sport. A quick rotate and back sorts it.

Clearly it is a very confusing system which upsets a lot of people. It’s all in the name of these stupid tests which are meaningless anyway.
1.4TSI DSG Xcellence delivered 2/3/17 after 6 months wait. Brilliant Silver. 18" machined alloys. Park Assist. 360º cameras. Power boot. All driver assists. Alcantara. SEAT sound.


leWrat
Posts: 66
Joined: Sun Oct 14, 2018 8:42 pm
Location: United Kingdom

Re: Drive Mode resets to Normal after a re-started engine

Post by leWrat » Thu Nov 01, 2018 2:28 pm

The problem (and it is a problem if two indicators in a car conflict) still persists in the 1.5 Xl Lux that I took delivery of last week.
Further the same mismatch in dial/console profile can be seen when (only for DSG) you use the lever to change from D to S,
To see this, start the engine, pull back lever from P to D, then an extra pull back again to change to S(port). The profile (dial) LED remains as it was at startup, when it should change to Sport. This 'problem' still occurs even if you have changed the profile via the dial after starting the engine.

Re. the car being able to change the selected profile (LED) on the drive profile dial.
This does not require the dial to be manually turned, i.e. the selected drive profile dial LED can be changed without touching the dial.
To test this:
Start engine
Change the drive profile manually, this brings up the available profiles on the central display
Select a different profile via the display and you will see that the LED on the drive profile dial changes to match the profile that you selected using the central display.
i.e. the software changed the select drive profile dial LED.

Therefore I would expect the selected drive profile dial LED to also show D/normal on startup and to change from D (or whatever) to Sport and back when changing the profile via the pull back on DSG, so that the actual profile in use and the drive profile dial LED always match.
MY19 Ateca Xcellence Lux 1.5 in Rhodium Grey with spacesaver wheel.


Post Reply

Return to “Main Seat Ateca chat”