Navigation not working

Faults and Technical chat for the Seat Ateca
Post Reply
Graham B
Posts: 86
Joined: Sun Jun 25, 2017 2:11 pm
Location: Kent UK

Navigation not working

Post by Graham B » Sat Jul 07, 2018 7:19 pm

Has anybody out there had problems with the Sat Nav not loading. Mine doesn't work every 3rd or 4th time you switch on the car and then doesn't work for the entire journey until you turn the ignition off and start again then it might work it might not. Also I like to have the engine oil temp showing on the infotainment screen, this too has developed an intermittent fault. Just showing 3 bars, when you call up the oil temp on the dashboard it shows the correct temp. Dover dealer had the car for 10 days and they can't recreate the problems and doesn't want to help me anymore as I didn't get the car from them. The car is leased from VWFS and they won't even return my calls. I am thinking of not paying them until I get it fixed
Ordered 1.4 TSI Xcellence with heated front screen and panoramic sun roof in Rodium Grey. DELIVERED 12 SEPT FINALLY


Tet70
Posts: 426
Joined: Sun Mar 26, 2017 9:40 am
Location: Finland

Re: Navigation not working

Post by Tet70 » Mon Jul 09, 2018 12:52 pm

What is the sat nav saying, is there any error message? Usually it says something like "starting" and then "checking the map data" or something like that. If you get some error message, in which phase at the startup you get it?

You should also try to reboot the infotainment system, when that happens: press and hold the power button (left rotaty button) for about 10 seconds, until you see SEAT logo on the screen.
Jungle Green 1.4 TSI 4Drive DSG Style + quite a lot of extras. Delivered in less than 8 months. :roll:


Post Reply

Return to “Faults & Technical”